Программа ** C++Напишите программу, которая вводит два целых числа и находит их...

0 голосов
334 просмотров

Программа на C++

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.

Входные данные
Входная строка содержит два целых числа.

Выходные данные
Программа должна вывести произведение введённых чисел.

Примеры
входные данные
6 12
выходные данные
72
входные данные
-7 15
выходные данные
-105


Информатика (96 баллов) | 334 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

#include
using namespace std;  

int multiply(int x, int y)
{
    if(y == 0)
      return 0;
      if(y > 0)
      return (x + multiply(x, y - 1));
       if(y < 0)
      return -multiply(x, -y);
}
   
int main()
{
   int a, b;
   cin >> a >> b;
   cout << multiply(a, b) << endl;<br>   return 0;
}

(4.2k баллов)
0 голосов

#include
#include

int
main(void)
{
    int a = 0;
    int b = 0;
    scanf("%d %d", &a, &b);
    long long mul = 0;
    for (int i = 0; i < abs(a); i++) {
        mul += b;
    }
    if (a < 0) {
        mul = -mul;
    }
    printf("%lld\n", mul);
    return 0;
}

(2.9k баллов)