Написать программу (в Паскале) поиска элемента массива, равного 50

0 голосов
207 просмотров

Написать программу (в Паскале) поиска элемента массива, равного 50


Информатика (166 баллов) | 207 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const n=20; p=50;
var a:array[1..n+1] of integer;
i:integer;
begin
randomize;
for i:=1 to n do
 begin
 a[i]:=random(100);
 write(a[i]:4);
 end;
writeln;
a[n+1]:=p;
i:=1;
while a[i]<>p do i:=i+1;
if ielse writeln('Значения ',p,' в массиве нет');
end.

Пример:
76 27 15 97 12 14 72 50 51 8 40 47 38 28 30 47 31 4 94 3
Значение = 50 - это 8 элемент массива

(194k баллов)