Дано 6 цифр. Вывести есть ли среди них повторяющиеся. Написать программу Pascal ABC

0 голосов
40 просмотров

Дано 6 цифр. Вывести есть ли среди них повторяющиеся.

Написать программу Pascal ABC


Информатика (125 баллов) | 40 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var s: set of integer;
    i,a,k: integer;
begin
  s:=[]; k:=0;
  write('введите 6 чисел через пробел  ');
  for i:=1 to 6 do
  begin
    read(a);
    if a in s then inc(k);    
    s:=s+[a];
  end;
  if k>0 then writeln('есть повторяющиеся')
  else writeln('нет повторяющихся');
end.

введите 6 чисел через пробел  10 12 15 19 17 15
есть повторяющиеся

введите 6 чисел через пробел  17 19 21 13 14 15
нет повторяющихся

(9.7k баллов)