Помогите пожалуйста написать программу.(Информатика) 1)Элементы заданного массива X = (x1...

0 голосов
42 просмотров

Помогите пожалуйста написать программу.(Информатика)
1)Элементы заданного массива X = (x1 , x2, ...,xN ) переупорядочите следующим образом: X = (xN , xN-1 , ..., x1 ).


Информатика (136 баллов) | 42 просмотров
Дан 1 ответ
0 голосов

Var i,n,k: integer;
    a: array[1..100] of integer;
begin
  write('n = ');  readln(n);
  randomize;
  writeln('исходный массив:');
  for i:=1 to n do
  begin
    a[i]:=random(100)-50;
    write(a[i],' ');
  end;
  writeln;
  writeln('новый массив:');
  for i:=1 to n div 2 do
  begin
    k:=a[i];
    a[i]:=a[n-i+1];
    a[n-i+1]:=k;
  end;
  for i:=1 to n do write(a[i],' ');
end.

n = 10
исходный массив:
45 -29 -25 12 -38 5 15 16 47 -36
новый массив:
-36 47 16 15 5 -38 12 -25 -29 45


(9.7k баллов)