Написать программу которая решает уравнение ax^2+bx+c=0 . Если D<0 то решений нет , если...

0 голосов
38 просмотров

Написать программу которая решает уравнение ax^2+bx+c=0 . Если D<0 то решений нет , если D=0 то 1 корень. Еси D >0 - 2 корня


Информатика (36 баллов) | 38 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var (a,b,c):=ReadReal3('введите a, b и c через пробел');
var D:=b*b-4*a*c;
if D>0 then write('два различных корня: x1=',(-b+sqrt(D))/(2*a),'; x2=',(-b-sqrt(D))/(2*a)) else if D=0 then
write('два совпадающих корня: x1=x2=',-b/(2*a)) else
write('нет действительных корней');
end.

(150k баллов)