(** с++)Написать программу. Подсчет нулевых элементов в заданном одномерном массиве.

0 голосов
96 просмотров

(На с++)Написать программу. Подсчет нулевых элементов в заданном одномерном массиве.


Информатика (20 баллов) | 96 просмотров
Дан 1 ответ
0 голосов

Using namespase std;

void main ()
{
setlocale (LC_ALL, "Russian");
int n, k;\\размер массива и счетчик

cout << "Введите количество элементов массива" << endl;<br>cin >> n;
float *arr = new float[n]; \\создаем динамический массив, т.к. не знаем сколько дано элементов и какие они

\\заполнение массива с клавиатуры
for (int i=0; i{
cout << "Введите " << i << "-ый элемент массива" << endl;<br>cin >> arr[i];
}

\\вывод массива на экран
for (int i=0; i
\\подсчет нулевых элементов
k=0;
for (int i=0; i{
if (arr[i] == 0) k++
}

cout << "Количество нулевых элементов в заданном массиве = " << k;<br>}


(1.8k баллов)