"В классе 20 учеников писали диктант по русскому языку. Напишите программу,...

0 голосов
94 просмотров

"В классе 20 учеников писали диктант по русскому языку. Напишите программу, подсчитывающую количество двоек, троек, четверок, пятерок, полученных за диктант. Посчитать средний балл за диктант с точностью до сотых." написать программу в Паскаль


Информатика (135 баллов) | 94 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
var a:=ArrRandom(20,2,5);Write('Оценки за диктант: ');a.Println;
Writeln('Двоек: ', a.Where(t-> t = 2).Count);
Writeln('Троек: ', a.Where(t-> t = 3).Count);
Writeln('Четверок: ', a.Where(t-> t = 4).Count);
Writeln('Пятерок: ', a.Where(t-> t = 5).Count);
Writeln('Средний балл за диктант: ', a.Average:0:2);
end.

Пример:
Оценки за диктант: 4 3 2 3 5 3 3 2 5 2 3 5 4 3 3 4 2 2 3 2
Двоек: 6
Троек: 8
Четверок: 3
Пятерок: 3
Средний балл за диктант: 3.15


(8.8k баллов)