Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8. Определите...

0 голосов
338 просмотров

Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8. Определите значение суммы после выполнения следующего фрагмента программы: sum:=0; for i:=3 to 7 do if r[i]>5 sum:=sum+r[i]; writeln (sum);


Информатика (16 баллов) | 338 просмотров
Дан 1 ответ
0 голосов
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:array of integer := (0,12,3,-5,-6,4,9,0,8);
var sum:= 0;
for var i := 3 to 7 do
 if a[i]>5 then
 sum:=sum+a[i];
 writeln (sum);
end.

Ответ: 9

(8.8k баллов)