Написать программу, которая вычисляет наибольший общий делитель двух целых чисел Паскаль

0 голосов
65 просмотров

Написать программу, которая вычисляет наибольший общий делитель двух целых чисел
Паскаль


Информатика (99 баллов) | 65 просмотров
Дан 1 ответ
0 голосов

Var  a, b: integer;
begin
Writeln('Введите два числа');
Readln(a, b); 
repeat 
if a > b then a := a Mod b    else
b := b Mod a; 
until (a = 0) Or (b = 0); 
writeln('НОД = ', a + b); 
end.

(402 баллов)