НЕLP. Напишите программу по поиску наименьшего элемента в массиве (массив заполнить...

0 голосов
62 просмотров

НЕLP. Напишите программу по поиску наименьшего элемента в массиве (массив заполнить случайными числами из диапазона от -5 до 44)


Информатика (71 баллов) | 62 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1623 от 16.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-5,44); a.Println;
  Writeln('Min=',a.Min)
end.

Пример
n= 13
18 2 33 43 16 28 19 15 31 5 15 -3 20
Min=-3
(150k баллов)
0 голосов
//Написано на PascalABCCompiler.Core v3.3.0.1540 (16.09.2017)
var
    arr: array[1..20] of integer;
    m: integer := 45;
begin
    for var k := 1 to 20 do
    begin
        arr[k] := random(49) - 5;
        if arr[k] < m then m := arr[k];
    end;
    write('Исходный массив: ');
    for var k := 1 to 20 do
    begin
        write(arr[k], ' ');
    end;
    writeln;
    write('Наименьшее число массива: ', m);
end.
(14.5k баллов)
0

СПАСИБО❤