Написать программу в Pascal, которая сортирует массив и находит количество различных...

0 голосов
163 просмотров

Написать программу в Pascal, которая сортирует массив и находит количество различных чисел в нём


Информатика (343 баллов) | 163 просмотров
0

Массив как заполнять? Read или рандомными значениями?

0

random

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
  a.Sort; a.Println;
  Writeln('Кол-во разных чисел равно ',a.Distinct.Count)
end.

Пример
n= 13
-1 1 3 -2 8 -9 9 -1 -8 -8 9 -9 2
-9 -9 -8 -8 -2 -1 -1 1 2 3 8 9 9
Кол-во разных чисел равно 9

(150k баллов)