Напишите программу, которая получает три числа – рост трёх спортсменов, и выводит...

0 голосов
307 просмотров

Напишите программу, которая получает три числа – рост трёх спортсменов, и выводит сообщение "on growth!", если числа введены по возрастанию, или сообщение 'dont on growth!', если они введены в другом порядке

Например:
Входные данные
165 170 172

Выходные данные
on growth!

Например:
Входные данные
175 170 172

Выходные данные
dont on growth!
С++
Только использовать всякие if ,for,while,scanf,printf,#include
#include
#include ,main,getch, max,min, математические действия и остаток от деления. Если это потребуется.


Информатика (165 баллов) | 307 просмотров
0

Если stdio.h и scanf-printf, то это получается в стиле C, а не C++

0

да

Дано ответов: 2
0 голосов
Правильный ответ

#include
#include
#include


int main()
{
    setlocale(LC_ALL, "RUS");
    int g[3];
    for (int i = 0; i < 3; i++)
    {
        printf("Введите рост %d спортсмена >> ", i+1);
        scanf("%d", &g[i]);
    }
    if (g[0] < g[1] && g[1] < g[2])
        printf("on growth");
    else
        printf("don't on growth");
    system("pause");
}

(1.5k баллов)
0 голосов

Https://pastebin.com/a1Z4DbQ9

#include "stdafx.h"
#include
int main()
{
  int n;
  int save_n=0;
  bool b = true;
  for (int i = 0; i < 3; i++)
  {
    std::cin >> n;
    if (save_n>0&&save_n >= n&&b)
      b = false;
    save_n = n;
  }
  if (b)
   std::cout << "on growth!"<<"\n";<br>  else
    std::cout << "dont on growth!"<<"\n";<br>  system("pause");
 return 0;
}

(1.7k баллов)