Помогите написать программу!

0 голосов
50 просмотров

Помогите написать программу!


image

Информатика (132 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Var
   Mass:array[1..12] of integer;
   i,o,p:integer;
Begin
Write('Введите массив: ');
For i:= 1 to 12 do Read(Mass[i]);
Write('Вывод введённого массива:');
o:=0;
p:=0;
For i:= 1 to 12 do
    Begin
    Write(' ',Mass[i]);
    if Mass[i] < 0 then o:=o+1
    else if Mass8[i] > 0 then p:=p+1;
    End;
WriteLn;
WriteLn('Количество положительных чисел: ',p);
WriteLn('Количество отрицательных чисел: ',o);
End.


Введите массив: 1 2 3 -4 -5 -6 7 8 9 10 11 12
Вывод введённого массива: 1 2 3 -4 -5 -6 7 8 9 10 11 12
Количество положительных чисел: 9
Количество отрицательных чисел: 3

(6.6k баллов)