Помогите! Тема была циклы. Нужно нарисовать блок схему и написать программу ** языке ТП(...

0 голосов
64 просмотров

Помогите!
Тема была циклы. Нужно нарисовать блок схему и написать программу на языке ТП( ТурбоПаскаль)
Пожалуйста, если можно то по подробнее!
Задача во вложении!


image

Информатика (1.1k баллов) | 64 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Блок-схемы - в прилагаемых файлах.
Программы:
1)
var i:integer; p:longint;
begin
p:=1;
for i:=5 to 12 do p:=p*i;
writeln('p = ',p);
readln;end.

var i:integer; p:longint;
begin
p:=1;
for i:=12 downto 5 do p:=p*i;
writeln('p = ',p);
readln;end.

Результат:
p = 19958400


image
(194k баллов)
0

p:longint; что это, можете подсказать?