1.Напишите программу, вычисляющую значение функции:y =5 при x<2 2 при x=2 10 при...

0 голосов
64 просмотров

1.Напишите программу, вычисляющую значение функции:y =5 при x<2 2 при x=2 10 при x>2(программа Паскаль)
2.Дан условный оператор:
If a<7 then c:=10<br> else if a>7 then c:=2
else c:=5
Какое значение имеет переменная а, если в результате выполнения условного оператора переменной с присваивается значение 5?
(программа Паскаль)


Информатика (116 баллов) | 64 просмотров
0

Что значит "x<2 2" и "x=2 10" ??

0

у=2 при x=2; у=10 при x>2

Дан 1 ответ
0 голосов
Правильный ответ

Var
Y,X:real;
Begin
Write('X = ');ReadLn(X);
if X<2 then Y:=5<br>else if X=2 then Y:=2
     else Y:=10;
WriteLn('Y = ',Y);
End.


2)

c = 5, когда не выполняется оба условия, то есть:


If a<7 then c:=10        // a>=7
else if a>7 then c:=2    // a>7
else c:=5

Переменная a может иметь любое значение больше семи.

(34.0k баллов)