Написать программу ** языке Си Дано число х в 10 системе счисления. Перевести его в...

0 голосов
35 просмотров

Написать программу на языке Си
Дано число х в 10 системе счисления. Перевести его в систему счисления с основанием n


Информатика (868 баллов) | 35 просмотров
0

С двоичной и до десятичной - только цифры. вплоть до 36-ричной можно использовать цифры и буквы A B C... X Y Z - а дальше? Буквы русского алфавита?)) или n<=36

Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
using namespace std;

int main()
{
    int x,n;
     string S;
     cout << "x = ",cin >> x;
     cout <<"n = ",cin >> n;
    while(x / n > 0){
        cout <<x / n<<" "<<x % n<<"\n";<br>        S = (char)(x % n<10?x % n+'0':x % n+'A'-10)+S;<br>        x = x / n;
        }
    if(x!=0){S = (char)(x<10?x+'0':x+'A'-10)+S;}<br>    cout <<"x_n = "<<S<<"\n";<br>     system("Pause");
     return 0;
}


(34.0k баллов)