Помогите составить программу для 6-ой задачи!(см.картинку)

0 голосов
46 просмотров

Помогите составить программу для 6-ой задачи!(см.картинку)


image

Информатика (100 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var A,B,i,k,p:integer;
Begin
k:=0;
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
For A:= A to B do
    Begin
    p:=0;
    i:=1;
    Repeat
    i:=i+1;
    if A mod i = 0 then p:=p+1;
    Until i>=A;
    if p = 1 then k:=k+1;
    End;
WriteLn(k);
End.

(34.0k баллов)