Напишите программу, которая удаляет из строки все повторяющиеся символы. Входные данные...

0 голосов
207 просмотров

Напишите программу, которая удаляет из строки все повторяющиеся символы.
Входные данные
На вход программы подаётся строка, содержащая символы таблицы ASCII.
Выходные данные
Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.
Примеры
входные данные
abc13a1b2z3c
выходные данные
abc132z
входные данные
QWasd123
выходные данные
QWasd123
Pascal ABC 1.8


Информатика (36 баллов) | 207 просмотров
Дан 1 ответ
0 голосов

Var s:string;
i,j:byte;
begin ;
writeln('Введите слово с повторябщимися символами');
readln(s); i:=1;
while iif s[i]<>' ' then  begin
for j:=length(s) downto i+1 do
if s[j]=s[i] then delete(s,j,1);
i:=i+1;
end
else i:=i+1;
write(s);
readln
end.

(147 баллов)