ПОМОГИТЕ ЭТО ОЧЕНЬ ВАЖНО! fpc - Free Pascal 2.6.2-8 gcc - GNU C 4.8.2 python - Python...

0 голосов
65 просмотров

ПОМОГИТЕ ЭТО ОЧЕНЬ ВАЖНО!
fpc - Free Pascal 2.6.2-8
gcc - GNU C 4.8.2
python - Python 2.7.6
javac - Java JDK 1.7.0_45
python3 - Python 3.4.0

Недавно Король побывал с официальным визитом в городе L. и под впечатлениями от города решил в своем Королевстве тоже развивать туризм.

С этой целью уже закуплено несколько экипажей и принят проект создания Центральной Конной станции (ЦКС).

Однако, две большие проблемы мешают начать реализацию проекта.

Во-первых, в Королевстве не так много площадок для карет (большая часть территории занята тюльпанами Королевы-бабушки, а она ни за что не позволит их забрать).

Во-вторых, ни в семье, ни в администрации Короля не могут договориться, на каком из площадок строить ЦКС.

Королева хочет, чтобы он был как можно ближе к ее оранжереи и все гости видели волшебные деревья.

Принцесса настаивает, чтобы ЦКС сооружали у Театра, которым она так восхищается.

Принц считает жемчужиной Королевства его гольф-клуб, Секретарь Короля - новый ресторан и т.д ...

Король уже запутался с расчетами и попытками найти компромиссное решение.

Мудрый Советник предложил выбрать для ЦКС то из площадок, от которого расстояние до самого дальнего из важных Королевских Объектов будет наименьшей.

Король согласился с решением Советника, но не знает как определить, на каком из площадок строить ЦКС. Поможем Королю?

Входные данные (вводятся с клавиатуры):

В первой строке одно целое число N (1 ≤ N ≤ 500), что задает количество Королевских Объектов, которые нужно учитывать в выборе площадки ЦКС.

В следующих N строках по два действительных числа, задающие координаты (x и y) каждого из объектов.

Далее в отдельной строке одно целое число M (1 ≤ M ≤ 100), что указывает количество возможных точек расположения ЦКС.

В следующих M строках по два действительных числа, задающие координаты (x и y) каждой площадки.

Примечание: упрощенно считаем, что дороги от каждого из площадок ко всем объектам прямолинейны.

Результат: Одно целое число n (1 ≤ n ≤ N), задающее номер выбранного для ЦКС площадки (расстояние до самого дальнего из объектов от этой площадки должно быть наименьшим среди всех площадок).


Информатика (15 баллов) | 65 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var
  arnx,armx,arny,army,delMmax:array[1..1000] of real;
  N,M,res,i,j:integer;
  min:real;
begin
min:=maxreal;
{не уверен существует ли эта константа в fpc, если что, она равна максимальному значению типа real}
readln(N);
for i:=1 to N do
    readln(arnx[i],arny[i]);
readln(M);
for i:=1 to M do
  begin
    readln(armx[i],army[i]);
    delMmax[i]:=-1;
    for j:=1 to N do
      if delMmax[i] then
 delMmax[i]:=sqrt(sqr(armx[i]-arnx[j])+sqr(army[i]-arny[j]));
    if delMmax[i] then
      begin
        min:=delMmax[i];
        res:=i;
      end;
 end;
writeln(res);
end.

Пример ввода:
3
2 1
1 2
1 1
3
1 5
3 3
4 2
Пример вывода:
2

(38.6k баллов)