ВЫЧИСЛИТЬ ПЕРИМЕТР КВАДРАТА, ЕСЛИ ИЗВЕСТНА ЕГО ПЛОЩАДЬ! Напишите программу в FreePascal!!...

0 голосов
68 просмотров
ВЫЧИСЛИТЬ ПЕРИМЕТР КВАДРАТА, ЕСЛИ ИЗВЕСТНА ЕГО ПЛОЩАДЬ! Напишите программу в FreePascal!! Cрочно

Информатика (14 баллов) | 68 просмотров
0

Perimeterr=sqrt(Square)*4;

Дан 1 ответ
0 голосов

{Должно работать так:}
{Вариант для Borland Pascal 7.1}
{Лучше, чем ничего}

program squarrel;
var a:real;

begin
writeln('square?');
readln(a);
if(a<0) then writeln('square MUST be more or equal than 0.')<br>else begin a:=sqrt(a)*4; writeln('square is', a:2:2); end;
readln;
end.

(46 баллов)