Написать программу (язык программирования - паскаль), которая выводит таблицу значений...

0 голосов
62 просмотров

Написать программу (язык программирования - паскаль), которая выводит таблицу значений функции y=|x-2|+|x+1|. Диапазон изменения аргумента от -4 до 4, шаг приращения аргумента - 0,5.


Информатика (45 баллов) | 62 просмотров
Дан 1 ответ
0 голосов

Var x:real;
begin
  x := -4;
  while x <= 4 do begin<br>    writeln('x=',x : 2 : 2,' y=', abs(x-2)+abs(x+1) : 2 : 2);
    x := x + 0.5;
  end;
  readln; //задержка ввода
end.

(444 баллов)