В паскале составить программу которая формирует массив из 16 случайных целых чисел в...

0 голосов
69 просмотров

В паскале составить программу которая формирует массив из 16 случайных целых чисел в промежутке от -12 до 10 и подсчитывает кол-во элементов кратных 3


Информатика (133 баллов) | 69 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(16,-12,10); a.Println;
  Writeln('Кол-во кратных 3 элементов равно ',
    a.Where(x->x mod 3=0).Count)
end.

Пример
-12 -2 6 -10 8 2 -5 -2 4 5 -10 6 -12 1 -6 -8
Кол-во кратных 3 элементов равно 5
(150k баллов)
0 голосов

При копировании кода на сайт из IDE автоматически убираются пробелы. Ниже будет скриншот того, как должен будет выглядеть код.

program zn; begin  var a: array [1..16] of integer;  var i, c: integer;  c:=0;  for i:=1 to 16 do   begin  a[i]:=random(20)-12;  writeln(a[i],' ');  if a[i] mod 3=0 then c:=c+1;  end;  writeln('Кол-во элементов кратных 3: ', c);  end.


image
(1.5k баллов)