РЕБЯТ, ПОМОГИТЕ ПОЖАЛУЙСТА. КОНЕЦ СЕМЕСТРА, Я В ЗАВАЛЕ :( задача 1) Написать программу,...

0 голосов
38 просмотров

РЕБЯТ, ПОМОГИТЕ ПОЖАЛУЙСТА.

КОНЕЦ СЕМЕСТРА, Я В ЗАВАЛЕ :(

задача 1)

Написать программу, которая по вводимому числу от 1 до 11 (номеру класса) выдаёт соответствующее приветствие. Например, если k=1 - «Привет, первоклассник» , если k=9 - «Привет, девятиклассник». Учесть возможную ошибку при вводе числа с клавиатуры.

задача 2)

Спомощью оператора Case составить программу определения стоимости разговора по телефону с учётом скидки 20%, предоставляемой по субботам и воскресеньям. Минута разговора стоит 2,3 руб.Вывести: день недели звонка, сумму без скидки и сумму со скидкой. Если скидка не предоставляется - написать об этом.


Учесть возможную ошибку при вводе числа с клавиатуры.


Пояснение: с клавиатуры пользователь вводит длительность разговора и номер дня недели от 1 до 7.)


Информатика (29 баллов) | 38 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

program Hello;
var i:integer;
begin
  write('введите целое число от 1 до 11: ');
  readln(i);
  writeln('**********************************');
case i of
    '1' : WriteLn('Привет, первоклассник!!!');
    '2' : WriteLn('Привет, второклассник!!!');
    '3' : WriteLn('Привет, третьеклассник!!!');
    '4' : WriteLn('Привет, четвероклассник!!!');
    '5' : WriteLn('Привет, пятиклассник!!!');
    '6' : WriteLn('Привет, шестиклассник!!!');
    '7' : WriteLn('Привет, семиклассник!!!');
    '8' : WriteLn('Привет, восьмиклассник!!!');
    '9' : WriteLn('Привет, девятикласссник!!!');
    '10' : WriteLn('Привет, десятиклассник!!!');
    '11' : WriteLn('Привет, одиннадцатиклассник!!!');
    else writeln('вы должны ввести число от 1 до 11')
  end;
  writeln('**********************************');
end.

 

 

 

program Phone;
var day:integer; time:real; week:array[1..7] of string;
begin
  week[7]:='Воскресенье';
  week[6]:='Суббота';
  week[5]:='Пятница';
  week[4]:='Четверг';
  week[3]:='Среда';
  week[2]:='Вторник';
  week[1]:='Понедельник';
  write('введите длительность разговора в минутах ');
  readln(time);
  write('введите номер дня недели ');
  readln(day);
  writeln('***** alphaeus is thinking...  *****');
  case day of
    '1'..'5':
       begin
         writeln(week[day]);
         writeln('Сумма без скидки - ', 2.3*time);
         writeln('Сумма скидкой - ', 0.8*2.3*time);
         writeln('Скидка не предоставляется');
       end;
    '6','7':
       begin
         writeln(week[day]);
         writeln('Сумма без скидки - ', 2.3*time);
         writeln('Сумма скидкой - ', 0.8*2.3*time);
         writeln('Вам предоставлена скидка!');
       end;
    else writeln('вы ввели неправильный номер дня недели')
  end;
  writeln'************************************');
end.

(52.6k баллов)
0 голосов

А можно поподробнее что подразумевается под учесть ошибку, имеется ввиду если число не соответсвует от 1 до 11 вывести "ошибка при вводе"?