Помогите составить программу, это срочно!!! Четвертое задание на фото!!!
Var a,b,min,i:integer; begin read(a); min:=0; for i:=1 to (a-2) do begin read(b); if (b mod 10=6) and ((bthen min:=b; read(b); end; write(min); end.