50+лучший Составьте программу, по которой компьютер десять раз запросит ввод любых чисел...

0 голосов
66 просмотров

50+лучший
Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел
(массив не использовать). Сделайте три варианта программы, используя операторы While,Repeat, For.


Информатика (527 баллов) | 66 просмотров
0

язык программирования какой?

Дано ответов: 2
0 голосов
Правильный ответ

Через while:

var
  s, x, i: integer;
  sr: real;
begin
  s:=0; i:=0;
  while i < 10 do
  begin
    readln(x);
    s := s + x;
    inc(i);
  end;
  sr := s / i;
  writeln(sr);
end.

Через repeat:

var
  s, x, i: integer;
  sr: real;
begin
  s:=0; i:=0;
  repeat
    readln(x);
    s := s + x;
    inc(i);
  until i = 10;
  sr := s / i;
  writeln(sr);
end.

Через For:

var
  s, x, i: integer;
  sr: real;
begin
  s:=0;
  for i:=1 to 10 do
  begin
    readln(x);
    s := s + x;
  end;
  sr := s / i;
  writeln(sr);
end.    

(15.5k баллов)
0 голосов

Var i: integer;
    a,s: real;
begin
  s:=0;
  writeln('числа:');
  for i:=1 to 10 do
  begin
    write(i,': ');
    readln(a);
    s:=s+a;
  end;
  writeln('среднее арифметическое: ',s/10:6:2);
end.    


(9.7k баллов)