Напишите программу: ввести четырехзначное число, найти сумму крайних и сумму средних цифр

0 голосов
116 просмотров

Напишите программу: ввести четырехзначное число, найти сумму крайних и сумму средних цифр


Информатика (52 баллов) | 116 просмотров
Дан 1 ответ
0 голосов

На Pascal:
program sum4;uses crt;var a:integer;
begin writeln('Введите 4-х значное число');readln(a); writeln('Сумма крайних цифр = ',(a mod 10)+(a div 1000)); writeln('Сумма средних цифр = ',((a div 100) mod 10)+(a div 10) mod 10);end.

(272 баллов)