Написать программу в Паскале.
Var a,k:int64; begin read(a); while a>=7 do begin if (a mod 7)=3 then inc(k); a:=a div 7; end; if a=7 then inc(k); write(k); end.