** языке СИ. Напишите программу, которая получает два целых числа A и B (0 < A < B) и...

0 голосов
219 просмотров

На языке СИ. Напишите программу, которая получает два целых числа A и B (0 < A < B) и выводит квадраты всех натуральных чисел в интервале от A до B.
Пример:
Введите два целых числа:
10 12
10*10=100
11*11=121
12*12=144


Информатика (24 баллов) | 219 просмотров
0

А C++ подойдёт? ;)

0

ДА

Дан 1 ответ
0 голосов

#include
#include
using namespace std;

int main()
{
    setlocale(LC_ALL,"Russian");
    unsigned long long A,B;
    cout << "Введите A(Начало) и B(Конец):\t";<br>    cin >> A >> B;
    if (A>0)
        for (unsigned long long i=A; i<=B; i++)<br>            cout << i << "\t - \t" << i*i << endl;<br>    else
    {
        cout << "Ошибка!";<br>        _getch();
        return -1;
    }
    _getch();
    return 0;
}

P.S. Это моя старая программа на C++, ПИСАЛ ЕЁ ДАВНО, использовал Microsoft Visual C++ 2010.


(101 баллов)