Составить программу в Паскаль:Даны 4 числа,выделить целые части и найти среднее...

0 голосов
35 просмотров

Составить программу в Паскаль:Даны 4 числа,выделить целые части и найти среднее арифметическое этих чисел.


Информатика (402 баллов) | 35 просмотров
0

Вообще смешная задача - для калькулятора.

Дан 1 ответ
0 голосов
Правильный ответ

Var
  i:integer;
  a,c:real;
begin
  c:=0;
  Writeln('Введите четыре произвольных числа');
  for i:=1 to 4 do
  begin
    Read(a); c:=c+Int(a)
  end;
  c:=c/4;
  Writeln('Среднее арифметическое равно ',c)
end.

Тестовое решение:
Введите четыре произвольных числа
4.7 5.03 4.12 5
Среднее арифметическое равно 4.5

(142k баллов)