Помогите , пожалуйста. Задача пр информатике. Изучили операторы for, if ,while , repeat ....

0 голосов
29 просмотров

Помогите , пожалуйста. Задача пр информатике. Изучили операторы for, if ,while , repeat . Составьте программу , пожалуйста. Если на одну чашу весов посадить мальчика , который весит n - кг , а на др. чашу весов насыпать n-кг конфет , к мальчику посадить девочку , которая весит на 5 кг меньше , а конфеты гораздо тяжелее детей , сколько необходимо съесть конфет детям , чтобы чаши весов уравновесились ?


Информатика (12 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

var
 n,m,i:integer;
 begin
 write('Введие вес мальчика: ');
 readln(n);
 write('Введите массу конфет (кг): ');
 readln(m);
 i:=0;
 while n+n-5<>m do
 begin
   i:=i+1;
   m:=m-1;
 end;
 writeln('Детям необходимо сьесть ',i,' кг конфет');
 end.

(1.1k баллов)