Срочно(((Помогите написать программу к рисунку.

0 голосов
50 просмотров

Срочно(((Помогите написать программу к рисунку.


image

Информатика (15 баллов) | 50 просмотров
0

начало программы :uses crt:integer; begin readln (x,y); if (x^2+y^2=36) and...

0

а далее тупик

0

откуда мы взяли 36?

0

а какие еще цифрки мы знаем?

0

(x^2+y^2<=36)

0

и еще y>0? а потм уже каждую четверть отдельно

0

Ладно

0

спасибо, что уделили мне время

0

так получилось?

0

да

Дан 1 ответ
0 голосов
Правильный ответ

Var
    x, y, r_small, r_big: integer;

begin
    readln(r_small, r_big);
    readln(x, y);
    Println(x * x + y * y <= r_big * r_big);<br>    if (x * x + y * y <= r_big * r_big) and (y >= 0) and
        ((x <= 0) or ((x >= 0) and (x * x + y * y >= r_small * r_small))) then
        writeln('Да')
    else
        writeln('Нет');
end.

(53.1k баллов)