Напишите программу ** языке программирования (или составьте алгоритм). Заполнить массив...

0 голосов
85 просмотров

Напишите программу на языке программирования (или составьте алгоритм).
Заполнить массив В, состоящий из сорока элементов, случайными целыми числами
из интервала [–30; 50] и найти максимальный элемент.


Информатика (12 баллов) | 85 просмотров
Дан 1 ответ
0 голосов

 var i,max:integer;
      b:array[1..40] of integer;
begin
  randomize;
  for i:=1 to 40 do
     begin
      b[i]:=random(random(80))-30;
      write(b[i],' ');
    end;
    writeln;
    max:=b[1];
  for i:=1 to 40 do
     begin
      if b[i]>= max then
        begin
          max:=b[i];
         end;
    end;
  writeln('Максимальный элемент массива: ',max);
end.

(1.8k баллов)
0

а почему интервал от 1 до 40,а не от -30 до 40,как в условии

0

Это не интервал а размер массива

0

Интервал записан в 7 строке

0

Кстати там просто random(80)-30 не знаю почему я там бред написал xD

0

Кстати там просто random(80)-30 не знаю почему я там бред написал xD