Пожалуйста, помогите написать программу в паскале. Дано число N. Найти сумму его...

0 голосов
36 просмотров

Пожалуйста, помогите написать программу в паскале. Дано число N. Найти сумму его делителей.


Информатика (866 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var n,s,i:integer;
begin
write('N = '); readln(n);
if n>1 then s:=1+n else s:=1;
for i:=2 to n div 2 do
 if n mod i = 0 then s:=s+i;
writeln('S = ',s);
end.

Пример:
N = 12
S = 28

(194k баллов)