Напишите программу, которая определяет, является ли введенное число простым.

0 голосов
64 просмотров

Напишите программу, которая определяет, является ли введенное число простым.


Информатика (21 баллов) | 64 просмотров
Дано ответов: 2
0 голосов

Var
  n, i, f: integer;
begin
  write('Введите число: ');
  readln(n);
  i:= 0; f:=0;
  while i < n do
  begin
    i := i + 1;
    if n mod i = 0 then f := f + 1;
  end;
  if f = 2 then writeln('Простое')
  else writeln('Не простое');
end.

(13.9k баллов)
0

а проше?

0

for i ;= 2 to n-1 do if n mod i = 0 then writeln('не простое') halt

0 голосов

Программа на С++ с асимптотикой sqrt(N) во вложении

(2.8k баллов)