Написать программу, которая выведет из N чисел числа кратные 3 и максимальное из них,...

0 голосов
46 просмотров

Написать программу, которая выведет из N чисел числа кратные 3 и максимальное из них, если нет чисел кратных 3, вывести NO


Информатика (15 баллов) | 46 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//PascalABC.NET
//Версия 3.3, сборка 1611
begin
write('Введите n: ');
var a:=ArrRandom(ReadInteger(),1,100);
write('сгенерированный массив: ');
a.Println();
var b:=a.Where(x->x mod 3=0);
if(b.Count()<>0) then
begin
write('числа кратные 3: ' );
b.Println();
write('максимальное из кратных 3: ',b.Max());
end else write('no');
end.

(150k баллов)
0 голосов

Var
n,tmp, i, max:integer;
fl:boolean;
begin
Read(n);
fl:=false;
max:= -1000*1000*1000-13;
for i:= 1 to n do
  begin
  Read(tmp);
  if (tmp mod 3 = 0) then
    begin
    fl:= true;
    if (max       max:= tmp;
    writeln(tmp, ' ');
    end;
  end;
  if (fl) then Writeln('Максимальное: ', max)
  else Writeln('NO');
end.

(8.8k баллов)