Информатика, PascalABC, написать программу: Вычислить площадь и периметр правильного...

0 голосов
75 просмотров

Информатика, PascalABC, написать программу: Вычислить площадь и периметр правильного N-угольника, описанного около окружности радиуса R (рассмотреть N-целого типа, R-вещественного типа)


Информатика (12 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

Var n:integer;
  s,p,r:real;

begin
  readln(n,r);
  p:=2*n*tan(Pi/n);
  s:=p*r/2;
  writeln( 'Периметр ', p);
  writeln( 'Площадь  ', s);
end.

(13.9k баллов)