Господа программисты и те кто хорошо шарит в Pascal'е , помогите мне с задачами. Нужно...

0 голосов
30 просмотров

Господа программисты и те кто хорошо шарит в Pascal'е , помогите мне с задачами. Нужно решение срочно!

1.Составить наиболее краткий алгоритм вычисления на Pascal.
y=x^5
y=x^10
y=x^15
y=x^19

2. Составить алгоритм тройного обмена значениями переменных по схеме(на фотографии по номером 2)


image

Информатика (81 баллов) | 30 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

1. 
1)
var x,y:real;
begin
readln(x);
y:=x*x;
y:=y*y*x;
writeln('x^5=',y);
end.
2)
var x,y:real;
begin
readln(x);
y:=x*x;
y:=y*y*x;
y:=y*y;
writeln('x^10=',y);
end.
3)
var x,y:real;
begin
readln(x);
y:=x*x;
y:=y*y*x;
y:=y*y*y;
writeln('x^15=',y);
end.
4)
var x,y:real;
begin
readln(x);
y:=x*x;
y:=y*y*y*y*x;
y:=y*y*x;
writeln('x^19=',y);
end.
2.
var a,b,c,z,t:real;
begin
readln(a,b,c);
z:=a;
t:=b;
a:=c;
b:=z;
c:=t;
writeln('a=',a,'b=',b,'c=',c);
end.




(5.6k баллов)
0 голосов

Задание №1
//PascalABC.NET (версия 3.1, сборка 1198)
var
  x: integer;
  y: biginteger;

begin
  x:=readlninteger('Введите Х ');
  y := sqr(x) * sqr(x) * x;println(y);
  y := sqr(y);println(y);
  y := y * sqr(x) * sqr(x) * x;println(y);
  y := y * sqr(x) * sqr(x);println(y);
end.

Тестовое решение:
Введите Х  2
32
1024
32768
524288

Задание №2
//PascalABC.NET (версия 3.1, сборка 1198)
var
  a, b, c: integer;

begin
  readln(a, b, c);
  swap(a, b);swap(a, c);
  println(a, b, c);
end.

Тестовое решение:
1 2 3
3 1 2





(13.9k баллов)