Написать программу ** паскале и сделаь к ней блок схему 3/2+9/4+27/16+…x/y

0 голосов
38 просмотров

Написать программу на паскале и сделаь к ней блок схему
3/2+9/4+27/16+…x/y


Информатика (418 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

Вот держите !!!!!!!!!!!!!!!!
//PascalABC.NET 3.3,сборка 1611 от 06.01.2018

//Внимание! Если программа не работает, обновите версию!

begin

var n:=readinteger('n=');

var (a,b):=(3,2); var p:=0.0;

for var i:=1 to n do

begin

 p:=p+a/b;

a:=a*3; b:=sqr(b);

end;

Writeln('Сумма=',p);

end.


image
image
(2.3k баллов)