Дано целое число. Определить сколько в нем цифр 5. Написать программу в Паскаль АВС
Точно Pascal ABC? Не PascalABC.NET?
PascalABC.NET
// PascalABC.NET 3.1, сборка 1192 от 07.03.2016 begin Writeln('Количество пятерок в числе равно ', ReadInteger('n=').ToString.Where(c->c='5').Count) end. Тестовое решение: n= 3456453 Количество пятерок в числе равно 2
Сильная задача... решение в один оператор )))
Var ch, k: integer; begin k:=0; readln(ch); while ch>0 do begin If ch mod 10 = 5 then k:=k+1; ch:=ch div 10; end; writeln(k); end.