Пожалуйста помогите ! Написать программу для паскаль. Вычислить значение выражения с...

0 голосов
45 просмотров

Пожалуйста помогите !
Написать программу для паскаль. Вычислить значение выражения с использованием трех видов цикла . Дано натуральное число n .Вычислить :(2n +1)


Информатика (12 баллов) | 45 просмотров
0

так тут вообще без циклов решается....

0

нужно решить с использованием циклов

0

может условие неправильно тогда? ибо, если на вход получаем n=10, то выражение примет вид n=(2*10+1) и тут решается в одно действие, без всяких циклов.

0

все правильно )

0

паскаль, или C++?

0

паскаль

Дан 1 ответ
0 голосов

Var
n:integer;
Begin
 Write('Введите число n: ');
 Readln(n);
 Write('2 * ',n,' + 1 = ',2*n+1);
End.

(2.6k баллов)
0

тут нету цикла, а в условии - тремя видами циклов!

0

соглашусь