Написать программу которая выводит пример ** умножение однозначных чисел если не...

0 голосов
66 просмотров

Написать программу которая выводит пример на умножение однозначных чисел если не правильно то пишет не правильно и верный ответ ,а если правильно то правильно


Информатика (106 баллов) | 66 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  k,m,n:integer;
begin
  Writeln('Проверка знания таблицы умножения');
  Writeln('Вводите ответ или 0 для окончания работы');
  Randomize;
  repeat
    k:=Random(9)+1;
    m:=Random(9)+1;
    Write(k,' x ',m,' = '); Read(n);
    if n<>0 then
      if n=k*m then Writeln('Верно!')
      else Writeln('Неверно, ответ ',k*m)
  until n=0;
  Writeln('Всего доброго, приходите еще!')
end.

(150k баллов)