Написать программу в которой задано целое число n и выводится каждая его цифра в столбец....

0 голосов
19 просмотров

Написать программу в которой задано целое число n и выводится каждая его цифра в столбец. На ABC.Pascal


Информатика (26 баллов) | 19 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var n,k:integer;
begin
write('n='); readln(n);
while n<>0 do
 begin
 writeln(n mod 10);
 n:=n div 10;
 end;
end.

Пример:
n=12756
6
5
7
2
1

(194k баллов)