Написать программу для определения, является ли введённая буква русского алфавита гласной

0 голосов
172 просмотров

Написать программу для определения, является ли введённая буква русского алфавита гласной


Информатика (55 баллов) | 172 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017

begin
  var c:char;
  Write('Буква: '); Readln(c);
  if UpCase(c) in ['А','Е','Ё','И','О','У','Ы','Э','Ю','Я'] then
    Writeln('Это гласная буква')
  else Writeln('Это не гласная буква')
end.
(150k баллов)
0 голосов

Program prog;
Uses crt;

var s: char;

begin
clrscr;

write('Letter: ');
readln(s);
case s of
'ё', 'Ё','у','У','е','Е','ы','Ы','а','А','о', 'О','э','Э','я','Я','и','И','ю','Ю': writeln('Yes');
else writeln('No');
end;
end.

(9.6k баллов)