Напишите программу, которая "разворачивает" число наоборот, например, из числа 123 строит...

0 голосов
526 просмотров

Напишите программу, которая "разворачивает" число наоборот, например, из числа 123 строит число 321. Используйте функцию для выполнения этой операции. Входные данные Входная строка содержит одно натуральное число. Гарантируется, что число не оканчивается на 0. Выходные данные Программа должна вывести число, в котором цифры стоят в обратном порядке в сравнении с исходным.
Примеры входные данные 123
выходные данные 321
c++


Информатика (73 баллов) | 526 просмотров
0

Можешь либо умножать, либо переведи число в строку, узнай сколько там символов, учти динамический массив, присвой ему каждую цифру, выведи этот массив наоборот. PROFIT! :)

0

#include "iostream"

Дано ответов: 2
0 голосов

#include "iostream" #include "cstring" using namespace std; int main(){ char ch[1000] cin.get(ch,100); for(int i = strlen(ch); i < -1; i--){ cout << ch[i]; } return 0; }

(593 баллов)
0

Все

0

сори в  (ch,100,'\n'); ошибка выходит

0

Вс готово теперь должно работать

0 голосов

Ответ в приложенном файле.


image
(577 баллов)