Напишите программу, которая вводит натуральное число N и выводит ** экран чётные...

0 голосов
72 просмотров

Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем N , в порядке убывания.


Информатика (14 баллов) | 72 просмотров
Дан 1 ответ
0 голосов

Var n,k,m: integer;
begin
  write('число:  ');  readln(n);
  m:=1;
  k:=trunc(log2(n));
  if (k mod 2)=1 then   m:=m shl (k-1)
  else m:=m shl k;
  repeat
    write(m,' ');
    m:=m shr 2;
  until m<2;<br>  end.

(9.7k баллов)
0

Лучший