Написать программу ** языке си++ вычислить сумму ряда до 20 члена s=((-1)*(k!+1)*x^k)/3^k

0 голосов
15 просмотров

Написать программу на языке си++ вычислить сумму ряда до 20 члена s=((-1)*(k!+1)*x^k)/3^k


Информатика (23 баллов) | 15 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Исходя из вашего запроса:
без отрицания k
#include
using namespace std;
int main()
{   
int a,k,s,x;
 for (k=0; k<20; k++)<br>{       
s +=((-1)*(k+1)*x^k)/3^k;   
}   
cout << s << endl;    <br>system("pause"); // или _getch();
return 0;
}

с отрицанием k
#include
using namespace std;
int main()
{   
int a,k,s,x;   
for (k=0; k<20; k++)    <br>{       
s +=((-1)*(k+1)*x^k)/3^k;   
}   
cout << s << endl;    <br>system("pause"); // èëè _getch();   
return 0;
}
и формулируйте вопрос корректнее. 
в обоих решениях k=0 изначально

(6.8k баллов)
0

для второго варианта
s +=((-1)*(!k+1)*x^k)/3^k;