Помогите пожалуйста, срочно!!Написать программу в Турбо Паскале.Задание:Дан текстовый...

0 голосов
34 просмотров

Помогите пожалуйста, срочно!!
Написать программу в Турбо Паскале.
Задание:Дан текстовый файл f. Исключить гласные буквы из строк и поместить результат в файл q.


Информатика (16 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
var
  f, q: Text;
  i: integer;
  s: string;

begin
  Assign(f, 'in.txt');
  Reset(f);
  Assign(q, 'out.txt');
  rewrite(q);
  while not EOF(f) do
  begin
    readln(f, s);
    i := 1;
    while (i <= length(s)) do<br>    begin
      if (upcase(s[i]) in ['А', 'Е', 'Ё', 'И', 'О', 'У', 'Ы', 'Ю', 'Я']) then
        delete(s, i, 1);
      inc(i);
    end;
    writeln(q, s);
  end;
  close(f); close(q);
end.
(16.9k баллов)
0

большое спасибо!

0

курсор на строке close(q) и пишет, что файл не открыт

0

а, всё в порядке