Написать программу ** языке Pascal решения квадратного уравнения. Программа должна...

0 голосов
75 просмотров

Написать программу на языке Pascal решения квадратного уравнения. Программа должна проверять правильность введенных пользователем данных и в случае, если коэффициент при второй степени неизвестного равен нулю, выводить соответствующее сообщение.


Информатика (20 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

program uravnenie;
var
a, b, c: integer;
D, x1, x2: Real;
begin
writeln('Р Е Ш Е Н И Е К В А Д Р А Т Н О Г О У Р А В Н Е Н И Я');
writeln('ax^2 + bx + c = 0');
writeln('Введите коэффициент a');readln(a);
 if (a <> 0) then  begin
writeln('Введите коэффициент b');readln(b);
writeln('Введите коэффициент c');readln(c);
D := sqr(b) - 4 * a * c;
if (D > 0) then
begin
x1 := (-b - sqrt(D)) / (2 * a);
x2 := (-b + sqrt(D)) / (2 * a);
writeln('x1 = ', x1 : 5 : 4);
writeln('x2 = ', x2 : 5 : 4);
end
else if (D = 0) then
begin
x1 := -b / (2 * a);
writeln('x = ', x1 : 5 : 4);
end
else
writeln('Данное уравнение не имеет корней')
end
else
writeln('Данное уравнение не является квадратным')
end.

(535 баллов)