Ребят нужна срочно помощь!Помогите пожалуйста!Нужно написать программу ** паскале.

0 голосов
22 просмотров

Ребят нужна срочно помощь!Помогите пожалуйста!Нужно написать программу на паскале.


image

Информатика (834 баллов) | 22 просмотров
Дан 1 ответ
0 голосов

Var
  salary, payment, percent, max, balance, profit, gain: real;
  i: integer;
 
begin
  write('Z = ');
  read(salary);
  write('K = ');
  read(payment);
  write('P = ');
  read(percent);
  write('A = ');
  read(max);
  balance := 0;
  gain := 0;
  for i := 1 to 12 do
  begin
    balance := balance + salary - payment;
    profit := balance * percent / 100;
    balance := balance + profit;
    gain := gain + profit;
    if gain > max then break;
  end;
  writeln(gain);
end.

(13.3k баллов)