.Дано число к (0<к<366) числу к=1 соответствует день 1 января . среда .Напишите программу...

0 голосов
23 просмотров

.Дано число к (0<к<366) числу к=1 соответствует день 1 января . среда .Напишите программу которая опред. День который соотв.введеному числу к.<br> Ребята,умоляю очень срочно помогите решить.
Пожалуйста пожалуйста пожалуйста
очень прошу
даю 30 баллов
умоляю помогите


Информатика (16 баллов) | 23 просмотров
Дано ответов: 2
0 голосов

Var
    k: integer;

begin
    writeln('Введите число');
    readln(k);
    case(k mod 7) of
        1: writeln('Среда');
        2: writeln('Четверг');
        3: writeln('Пятница');
        4: writeln('Суббота');
        5: writeln('Воскресенье');
        6: writeln('Понедельник');
        0: writeln('Вторник');
    end;
end.

(1.3k баллов)
0 голосов

#include
using namespace std;

int main (){
setlocale(LC_ALL,"Rus");
int dp,N,S=7;
cout<<"\n  День=";<br>cin>>N;
while(N>S){ N=N-7;
}
 dp=N;
 switch(dp)
{
 
   case 1:
   
    cout<<"\n  Среда"<<endl;  <br>  break;
case 2:
   
    cout<<"\n  Четверг"<<endl;<br>    break;
case 3:   
    cout<<"\n  Пятница"<<endl; <br>   break;
case 4:
 
      cout<<"\n  Суббота"<<endl;  <br>  break;
 case 5: 
      cout<<"\n  Воскресенье"<<endl;  <br>  break;
case 6:
     
  cout<<"\n  Понедельник"<<endl;<br>    break;
 case 7:   
   cout<<"\n  Вторник"<<endl;  <br>  break;
  }
system("pause");
return 0;
}

(181 баллов)